Progetto

Generale

Profilo

Segnalazione #665

Mantenere allineato fuss-client-rpi a fuss-client

Aggiunto da Paolo Dongilli 6 mesi fa. Aggiornato 5 mesi fa.

Stato:
Risolto
Priorità:
Normale
Assegnato a:
Versione prevista:
-
Inizio:
09-11-2018
Scadenza:
% completato:

100%


Descrizione

Bisognerebbe allineare questa versione di fuss-client per RPi al fuss-client originale.

Revisioni associate

Versione 14c1c8e0 (diff)
Aggiunto da Elena ``of Valhalla'' Grandi 5 mesi fa

Only build an empty transitional package. refs: #665

Cronologia

#1 Aggiornato da Elena Grandi 5 mesi fa

  • Stato modificata da Nuovo a Commenti
  • Assegnato a modificata da Elena Grandi a Paolo Dongilli

Ho integrato queste modifiche in un apposito branch rpi sul repository principale del fuss-client; in questo modo in futuro per allineare fuss-client-rpi al fuss-client base sarà sufficiente:

  • mergiare master nel branch rpi e risolvere eventuali conflitti col relativo commit di merge;
  • creare una nuova entry nel changelog per fuss-client-rpi della versione opportuna
  • buildare il pacchetto.

#2 Aggiornato da Elena Grandi 5 mesi fa

  • Stato modificata da Commenti a In elaborazione
  • Assegnato a modificata da Paolo Dongilli a Elena Grandi

Ulteriore modifica: è stato introdotto supporto per il rasberry direttamente in fuss-client (versione 9.0.20, non ancora uploadata): a partire da quella versione slick-client viene installato solo nel caso ansible_lsb.id != "Raspbian" (e quindi non sui raspberry), permettendo di evitare di mantenere pacchetti diversi.

Sto preparando dei pacchetti fuss-client-rpi di compatibilità che dipendono da fuss-client >= 9.0.20.

Nel caso sia necessario, metterò condizionale anche l'installazione di samba-client (sto indagando se lo sia).

#3 Aggiornato da Elena Grandi 5 mesi fa

I pacchetti di compatibilità sono pronti sul branch transitional nel repository fuss-client-rpi, bisogna finire ed uploadare fuss-client 9.0.20 prima di poter uploadare anche loro.

Ho visto che c'è da indagare su #261 per poter togliere fuss-client-dependencies da quanto installato da ansible, per non dover gestire un secondo fuss-client-dependencies-rpi quasi uguale.

L'installazione di samba-client è stata resa condizionale.

#4 Aggiornato da Elena Grandi 5 mesi fa

  • Stato modificata da In elaborazione a Commenti
  • Assegnato a modificata da Elena Grandi a Paolo Dongilli

Uploadato:

  • fuss-client 9.0.20 con compatibilità raspbian
  • fuss-client-rpi 9.1.2 come pacchetto di transizione che dipende da fuss-client

samba-client e slick-greeter sono stati rimossi dalle dipendenze di fuss-client-dependencies (vengono comunque installati poi) per compatibilità, in attesa della soluzione elegante con ansible nuovo.

Aggiunta una nota a https://fuss-dev-guide.readthedocs.io/it/latest/fuss-client.html#compatibilita-raspbian (utile nel caso serva rendere condizionali altre parti)

#5 Aggiornato da Paolo Dongilli 5 mesi fa

  • Stato modificata da Commenti a Risolto
  • % completato modificata da 0 a 100

Esporta su Atom PDF