Project

General

Profile

Segnalazione #429

Problema con dipendenze Metapacchetto fuss-office

Added by Markus Pfeifer almost 5 years ago. Updated over 4 years ago.

Status:
Chiuso
Priority:
Normale
Assignee:
Start date:
09/26/2017
Due date:
% Done:

0%


Description

Oggi mattina ho fatto un aggiornamento su un client virtuale per motivi di prova.

lanciato "apt update" mi ha segnalato che c'era un aggiornamento per fuss-office.

lanciato "apt upgrade" mi ha aggiornato i paccheti.

eseguendo un ulteriore ricerca di aggiornamento per assicurarmi che non ce ne sono altri il sistema mi ha consigliato di rimuovere dei pacchetti non più in utilizzo e senza dipendenze.

lancianto "apt autoremove" tutta la suite libreoffice è stata rimossa.

Prego controllare le dipendenze dei pacchetti all'interno del metapacchetto.

Saluti
Markus.

History

#1 Updated by Christopher R. Gabriel almost 5 years ago

  • Status changed from Nuovo to Commenti
  • Assignee changed from Elena Grandi to Markus Pfeifer

Se e' stata rimossa la suite di openoffice, direi che e' stato rimosso anche fuss-office, visto che libreoffice non puo' essere rimosso senza aver tolto fuss-office:

cgabriel@fili ~/git/fuss/fuss-software/metapackages (master)$ apt-cache show fuss-office
Package: fuss-office
Source: fuss-software
Version: 8.0.58
Architecture: all
Maintainer: Christopher R. Gabriel <cgabriel@truelite.it>
Installed-Size: 30
Depends: calibre, gobby, libreoffice (>= 1:5.2), libreoffice-help-de, libreoffice-help-en-gb, libreoffice-help-es, libreoffice-help-fr, libreoffice-help-it, libreoffice-l10n-de, libreoffice-l10n-en-gb, libreoffice-l10n-es, libreoffice-l10n-fr, libreoffice-l10n-it, libreoffice-pdfimport, libreoffice-wiki-publisher, openclipart-libreoffice, libreoffice-gtk (>= 1:5.2)
cgabriel@fili ~/git/fuss/fuss-software/metapackages (master)$ apt-cache show fuss-office
Package: fuss-office
Source: fuss-software
Version: 8.0.58
Architecture: all
Maintainer: Christopher R. Gabriel <cgabriel@truelite.it>
Installed-Size: 30
Depends: calibre, gobby, libreoffice (>= 1:5.2), libreoffice-help-de, libreoffice-help-en-gb, libreoffice-help-es, libreoffice-help-fr, libreoffice-help-it, libreoffice-l10n-de, libreoffice-l10n-en-gb, libreoffice-l10n-es, libreoffice-l10n-fr, libreoffice-l10n-it, libreoffice-pdfimport, libreoffice-wiki-publisher, openclipart-libreoffice, libreoffice-gtk (>= 1:5.2)

Visto questo, direi che le dipendenze di fuss-office sono corrette. Attenzione che fuss-office dipende da pacchetti in backports, come richiesto qui: https://work.fuss.bz.it/projects/fuss/wiki/SoftwareFuss8#Metapacchetto-fuss-office e anche nel ticket #417, che implica l'uso esplicito dei repository da backports, ad esempio:

apt-get upgrade -t jessie-backports

#2 Updated by Markus Pfeifer almost 5 years ago

  • Status changed from Commenti to Chiuso

Quindi di default si fa l'upgrade usando il command apt upgrade -t jessie-backports ...

Bene che lo sapiamo che è questa la procedura di default ...

Grazie.

Saluti Markus.

#3 Updated by Markus Pfeifer almost 5 years ago

  • Assignee changed from Markus Pfeifer to Christopher R. Gabriel

Domanda ... usare apt update -t jessie-backports anche per il lato server?

Saluti
Markus.

#4 Updated by Christopher R. Gabriel over 4 years ago

  • Status changed from Chiuso to Commenti
  • Assignee changed from Christopher R. Gabriel to Markus Pfeifer

(era stato commentato dopo che e' stato chiuso, riapro)

Si, anche sul server ci sono pacchetti da backports.

Pe rirposndere al commenti precedente, non e' la "procedura di default", e' la procedura da fare quando ci sono pacchetti che aggiungono dipendenze che arrivano da backports, altrimenti risultano non installabili. Che e' quello che e' successo, e venendo chiesto esplicitamente un pacchetto proveniente da backports, davo per scontato che si conoscesse l'uso dei backports.

Mi sai dire qualcosa riguardo la rimozione di libreoffice che chiedevo nel commento 1 sopra?

#5 Updated by Markus Pfeifer over 4 years ago

Per il comento 1:

Da quello che avvevo notato è stato rimosso soltanto libre-office però non sono sicuro ... Siccome il sistema mi ha consigliato di lanciare la procedura di autorimozione dopo il classico "apt upgrade", non è che mi sono fatto tanti pensieri e poi siccome non sono un esperto su Linux, per mè ciò che il sistema ha fatto di conseguenza pensavo che fosse giusto. Ho notato dopo il riavvio che è stato rimosso qualcosa perchè le icona sulla barra di avvio in fondo erano non più riconosciuti.

Per fortuno questo problema si è presantato soltanto su un client virtuale che avvevo configurato per l'ambiente produttivo della scuola di pilota "Segantini" di Merano e quindi il danno non era grave.

Per il futuro utilizzerò sempre i backports per gli aggiornamenti e quindi problema è risolto ... ed inoltre non eseguerò mai più la procedura di autoremove ... così evito di svegliarmi la mattina con una scuola che non riesce più a lavorare.

Saluti
Markus.

#6 Updated by Markus Pfeifer over 4 years ago

  • Assignee changed from Markus Pfeifer to Christopher R. Gabriel

Per il comento 1:

Da quello che avvevo notato è stato rimosso soltanto libre-office però non sono sicuro ... Siccome il sistema mi ha consigliato di lanciare la procedura di autorimozione dopo il classico "apt upgrade", non è che mi sono fatto tanti pensieri e poi siccome non sono un esperto su Linux, per mè ciò che il sistema ha fatto di conseguenza pensavo che fosse giusto. Ho notato dopo il riavvio che è stato rimosso qualcosa perchè le icona sulla barra di avvio in fondo erano non più riconosciuti.

Per fortuno questo problema si è presantato soltanto su un client virtuale che avvevo configurato per l'ambiente produttivo della scuola di pilota "Segantini" di Merano e quindi il danno non era grave.

Per il futuro utilizzerò sempre i backports per gli aggiornamenti e quindi problema è risolto ... ed inoltre non eseguerò mai più la procedura di autoremove ... così evito di svegliarmi la mattina con una scuola che non riesce più a lavorare.

Saluti
Markus.

#7 Updated by Elena Grandi over 4 years ago

  • Assignee changed from Christopher R. Gabriel to Markus Pfeifer

Per l'uso di autoremove: segnalo che la buona pratica è di usarlo quando viene suggerito, controllando però con attenzione l'elenco dei pacchetti che verranno rimossi, ed evitando di dare l'ok alla rimozione nel caso in cui ci siano cose sospette.

Di solito i problemi non sono causati da autoremove, ma è autoremove che può permettere di accorgersi di problemi avvenuti in precedenza, come in questo caso l'aggiornamento non andato a buon fine di fuss-office.

#8 Updated by Markus Pfeifer over 4 years ago

  • Status changed from Commenti to Chiuso
  • Assignee changed from Markus Pfeifer to Elena Grandi
  • Priority changed from Alta to Normale

Vi ringrazio dell'atenzione che avete data a questo problema. Per mè addesso sembra tutto un pò più chiaro.

Riasumo:

per la distribuzione FUSS8 è consiglato utilizzare gli aggiornamenti jessie-backports sia per il client che anche per il server.

L'utilizzo dell'opzione di autoremove è anche consigliato però sempre controllando con cura ciò che autoremove vorrebbe rimuovere.

Grazie e saluti.
Markus.

Also available in: Atom PDF