Project

General

Profile

Segnalazione #168

password clonezilla

Added by Christopher R. Gabriel about 6 years ago. Updated almost 6 years ago.

Status:
Chiuso
Priority:
Normale
Start date:
01/20/2017
Due date:
% Done:

0%

Estimated time:

Description

DOpo installazione fuss-server, e avvio di client via pxe, non riesco a collegarmi con ssh per uploadare immagine, le credenziali dell'utente clonezilla nella home di root non sono buone.

History

#1

Updated by Simone Piccardi about 6 years ago

  • Assignee changed from Elena Grandi to Christopher R. Gabriel

Con quale installazione del server e con quale programma di virtualizzazione stai facendo le prove?

Il test che ho appena fatto con una debian liscia + fuss-server su Virtualbox non hanno questo problema. Le credenziali funzionano e si accede senza problemi.

#2

Updated by Christopher R. Gabriel about 6 years ago

  • Assignee changed from Christopher R. Gabriel to Elena Grandi

Simone Piccardi ha scritto:

Con quale installazione del server e con quale programma di virtualizzazione stai facendo le prove?

Server da ISO server, dove ho buildato e installato fuss-server da HEAD. Il problema ce l'ho sia con virtualbox debian che virtualbox oracle.

Il test che ho appena fatto con una debian liscia + fuss-server su Virtualbox non hanno questo problema. Le credenziali funzionano e si accede senza problemi.

Hai provato a fare piu' esecuzioni di fuss-server create?

#3

Updated by Simone Piccardi about 6 years ago

Christopher R. Gabriel ha scritto:

Hai provato a fare piu' esecuzioni di fuss-server create?

Una sola.

L'unico problema riscontrato è su #170, e comunque mi impediva l'avvio via PXE, fatto manualmente un restart gli altri problemi non si sono manifestati.

La iso nuova è disponibile o me la devo ricostruire?

#4

Updated by Elena Grandi about 6 years ago

  • Status changed from Nuovo to Commenti
  • Assignee changed from Elena Grandi to Christopher R. Gabriel

Ho provato ad eseguire due volte fuss-server create su macchina pulita e neanche io riesco a riprodurre il problema: l'utente fuss-server continua ad avere la password che viene salvata in /root/clonezilla_cred.txt.

Pensando a potenziali problemi, questi sono gli step che vengono fatti:

  • se necessario, viene creato l'utente clonezilla (senza fare nulla alla password).
  • verificare se il file /root/clonezilla_cred.txt esiste
  • solo se non esiste, viene generata una password
  • solo se non esiste, viene salvata lì dentro la password appena generata
  • solo se non esiste, viene crittata quella password ed impostata per l'utente

nessuna di queste operazioni dipende da fattori esterni (tipo presenza della rete), per cui ansible non ha motivo di interrompersi, e quindi dovrebbe tutto arrivare a buon fine.

Però se non ricordo male c'è stato un bug nella crittografia della password: è possibile che alla prima esecuzione si sia interrotto su quel bug (ora fixato) e che quindi sia rimasto con l'utente senza password impostata? Nel caso basta cancellare il file /root/clonezilla_cred.txt per farla ricreare.

Nel dubbio, ho spostato il salvataggio della password alla fine delle operazioni, così se c'è qualche fallimento intermedio all'esecuzione successiva non c'è il file nella home di root e ne viene ricreata una nuova.

#5

Updated by Christopher R. Gabriel almost 6 years ago

  • Status changed from Commenti to Chiuso

Ora non riesco piu' a riprodurlo, quindi a posto, chiudo.

Also available in: Atom PDF